The Steel Guitar Forum Store 

Post new topic S10 Sierra Audio Problems
Goto page Previous  1, 2
Reply to topic
Author Topic:  S10 Sierra Audio Problems
Chris Raven

 

From:
British Columbia, Canada
Post  Posted 5 Feb 2020 7:59 pm    
Reply with quote

Hi Jack: SUCCESSSSS I removed the Red wire from the center tap of the 3W switch and attached the black wire to that location. Now the 3W switch gives me very bright toggled outward, medium brightness toggled back towards the player and a kind of mellow tone in the middle. No distortion or any such thing. It must have been in the pot or the other switch. No matter it is working now with lots of volume so now I can turn the amp down and not have it blow me away when the old circuit decided that it would work...lol
Thanks for your help I do appreciate it.
View user's profile Send private message Send e-mail

Jack Goodson

 

From:
new brockton,alabama (deceased)
Post  Posted 6 Feb 2020 7:13 am     switch
Reply with quote

chris, that is great, there is nothing better than a good sounding sierra. i do not claim to be an expert on sierra,s but i have owned several over the years (fact is i have a stafford elegante 14 string) i just replaced the 3/way switch a few days ago in it.....thanks jack
View user's profile Send private message


All times are GMT - 8 Hours
Jump to:  
Please review our Forum Rules and Policies
Our Online Catalog
Strings, CDs, instruction, and accessories
www.SteelGuitarShopper.com
BIAB Styles
Ray Price Shuffles for Band-in-a-Box
by Jim Baron
The Steel Guitar Forum
148 S. Cloverdale Blvd.
Cloverdale, CA 95425 USA

Click Here to Send a Donation

Email SteelGuitarForum@gmail.com for technical support.