INSTRUCTION STRINGS ACCESSORIES MUSIC LINKS
 Visit Our Catalog at SteelGuitarShopper.com for Steel Guitars, Strings, Instruction, Music and Accessories 
Forum Index
where steel players meet online
The Steel Guitar Forum

Notice: Some forum emails are not being delivered. (Details)



Post new topic (Please Close) Help, guitar is breaking up!!!
This topic is locked: you cannot edit posts or make replies.
Author Topic:  (Please Close) Help, guitar is breaking up!!!
Mike Spaeth


From:
Central Illinois, USA
Post Posted 16 May 2017 9:30 am     Reply with quote

This problem came on suddenly this past Saturday night and I have no idea what to look for. It is breaking up like it has a loose wire but I can't find one
The guitar is a D-10 Carter and the problem is only happening to the E9th neck the C6th neck works fine
It happens with and without the volume pedal in the equation.
It will stop breaking up when you push the A or the C pedals ever so slightly and hold it there.
Any ideas on what to look for???

Thanks


Last edited by Mike Spaeth on 16 May 2017 2:35 pm; edited 1 time in total
View user's profile Send private message Send e-mail
Edward Rhea


From:
Medford Oklahoma, USA
Post Posted 16 May 2017 10:31 am     Reply with quote

Hmmm...I suspect a cold solder joint perhaps at the pickup switch? Look for a loose connection there and/or dull gray solder on/around the switch lug?
A dirty pickup switch could be the culprit as well, I suppose. Wishing you the best
_________________
Sho~Bud 6139 3&5
BJS bars
Sho~Bud seat & volume pedal
George L's cables
''71 Fender Twin Reverb w/JBL D120F's
"70 Fender Deluxe Reverb w/JBL D120F
National np2 & blue Herco picks
Ricky Davis signature Jagwires
View user's profile Send private message Send e-mail
Larry Jamieson


From:
Walton, NY USA
Post Posted 16 May 2017 12:32 pm     Reply with quote

Try spraying some contact cleaner/lube in your switch, then
work it back and forth several times. Also check all your cables.
View user's profile Send private message Send e-mail Visit poster's website
Mike Spaeth


From:
Central Illinois, USA
Post Posted 16 May 2017 2:34 pm     re Reply with quote

Thanks for the responses. I think Edward hit it. I re-melted the solder on one of the terminals that looked suspicious and it is working again!

Thanks!
View user's profile Send private message Send e-mail

All times are GMT - 8 Hours
Jump to:  

Our Online Catalog
Strings, CDs, instruction,
steel guitars & accessories

www.SteelGuitarShopper.com

Steel Guitar Music
Instrumental steel guitar CDs for your permanent collection
www.SteelGuitarMusic.com

BIAB Styles
Ray Price Shuffles
for Band-in-a-Box

by Jim Baron

Please review our Forum Rules and Policies

The Steel Guitar Forum
148 South Cloverdale Blvd.
Cloverdale, CA 95425 USA

Support This Forum

advertisement