| Visit Our Catalog at SteelGuitarShopper.com |

Post new topic noisy wet reverb
Reply to topic
Author Topic:  noisy wet reverb
Karen Sarkisian


From:
Boston, MA, USA
Post  Posted 16 Nov 2017 9:06 am    
Reply with quote

Wet Reverb causing some noise when I use it, regardless of whether its on or off, when its in the chain there is additional noise. Not getting the same noise with my Strymon El Cap pedal. both are on isolated power supply power.
anyone else with this issue ? its a great sounding reverb but I don't like the noise. Doesnt matter if its before or after the preamp, same noise issue.
_________________
Emmons
View user's profile Send private message Send e-mail Visit poster's website
George Macdonald


From:
Vancouver Island BC Canada
Post  Posted 16 Nov 2017 9:31 am     Wet reverb
Reply with quote

I have two Wet reverbs, one for my lap steel, [on a stand,] and one for my pedal steel. I haven't experienced the problem you described, but maybe try a different power adapter if you haven't already. If that doesn't work you might consider sending it to Neunaber in Calif. I'm sure they could solve the problem.
View user's profile Send private message Send e-mail
Karen Sarkisian


From:
Boston, MA, USA
Post  Posted 16 Nov 2017 9:48 am    
Reply with quote

for sure I will contact them. it sounds great, just frustrated with the noise issue (being super picky)...
_________________
Emmons
View user's profile Send private message Send e-mail Visit poster's website
Mitchell Smithey


From:
Dallas, USA
Post  Posted 18 Nov 2017 2:36 pm    
Reply with quote

Mine has developed a hum . Is that what you are getting?
View user's profile Send private message Send e-mail
Karen Sarkisian


From:
Boston, MA, USA
Post  Posted 18 Nov 2017 10:23 pm    
Reply with quote

Mitchell Smithey wrote:
Mine has developed a hum . Is that what you are getting?


yes
_________________
Emmons
View user's profile Send private message Send e-mail Visit poster's website
Tom Wolverton


From:
San Diego, CA
Post  Posted 20 Nov 2017 7:07 am    
Reply with quote

I had a reverb pedal get noisy the other day. It turned out that I had the input and outputs reversed. Once I fixed that, it was fine. The weird thing is that it sort of worked like that.
_________________
To write with a broken pencil is pointless.
View user's profile Send private message Send e-mail
Terry Lovett


From:
Texas, USA
Post  Posted 7 Jan 2018 8:17 am    
Reply with quote

Karen,

I'm curious if you resolved the hum issue with your pedal unit. Does your reverb device have a place to insert and use a battery?
_________________
"Things can work,but not as well as they might if your thinking had been better" - J. Williams, MIT
View user's profile Send private message Send e-mail Visit poster's website

All times are GMT - 8 Hours
Jump to:  
Please review our Forum Rules and Policies
Our Online Catalog
Strings, CDs, instruction, and steel guitar accessories
www.SteelGuitarShopper.com

Steel Guitar Music
Instrumental steel guitar CDs for your permanent collection
www.SteelGuitarMusic.com

BIAB Styles
Ray Price Shuffles for Band-in-a-Box
by Jim Baron

The Steel Guitar Forum
148 S. Cloverdale Blvd.
Cloverdale, CA 95425 USA

Support This Forum



advertisement