INSTRUCTION STRINGS ACCESSORIES MUSIC LINKS
 Visit Our Catalog at SteelGuitarShopper.com for Steel Guitars, Strings, Instruction, Music and Accessories 
Forum Index
where steel players meet online
The Steel Guitar Forum

Post new topic Nashville 112 Reverb Squealing!
Reply to topic
Author Topic:  Nashville 112 Reverb Squealing!
Jeff Metz Jr.


From:
York, Pennsylvania, USA
Post Posted 15 Oct 2017 2:48 pm     Reply with quote

If I turn my reverb up past 3 It begins a gradual squeal that eventually reaches a deafening volume level. If I turn the reverb knob down it goes away.
I would like to add a bit more reverb but this is hindering that option.
BTW this amp has a telonics 12" neo speaker and a MOD reverb Tank.
Thanks
_________________
Mullen G2 SD10 , Lil Izzy Buffer, Goodrich 120 volume pedal, Boss DD-7, Peterson Strobo flip, Peavey Nashville 112
View user's profile Send private message Send e-mail
Jack Stoner


From:
Inverness, Fl
Post Posted 16 Oct 2017 6:14 am     Reply with quote

I would suspect the "mod" reverb tank. Either defective, wrong impedance model, or possibly how or where its mounted.

It should be mounted on the bottom and as far the rear of the cabinet as possible to get away from the speaker. For testing, move the reverb tank out of the cabinet (as far as the cables will allow) and see if it makes any difference.
_________________
Franklin D-10, Hilton VP, POD X3, MatchBro, SG Black Box, Carvin BX500, EPS-15C, Sonar DAW but migrating to Studio One 3, MOTU 896mk3 Hybrid
R.O.P.E. Member
View user's profile Send private message Send e-mail
Tim Mathews


From:
Missouri, USA
Post Posted 30 Oct 2017 6:23 am     Pinching the tank Reply with quote

Sometimes if you have things "stuffed" into the back of the amp footwitch, stomp boxes, etc they can immobilize and transfer cabinet vibration to the tank causing what you describe. The reverb tank should always be loosely
attached and able to move. Hence the bag it sits in on the 112
View user's profile Send private message Send e-mail
Dag Wolf


From:
Bergen, Norway
Post Posted 12 Nov 2017 7:30 am     Reply with quote

I have the same problem with one of mine nv112 reverb. I`ve a couple and switched the reverb tank. The problem follows the tank.
Anyone got any tips or is the tank defect?

Thanks,
Dag
View user's profile Send private message Send e-mail
Jerry Knapper


From:
Polk City, Florida , USA
Post Posted 14 Nov 2017 7:04 pm     possible fix Reply with quote

I have an older KK ShoBud amp that often was noisy as I increase the reverb and then it would feedback. I played with it trying different things and discovered it was the tank itself causing the feedback. If I squeezed the tank it would stop. Thinking it was just my hand, I put a pinch clamp on it and that stopped it also. However, it wasn't practical to put a clamp on it so I played around some more and finally found that if I put some insulation between the board the tank was mounted on it would dampen the vibration. Experimenting with several things, I put some blue anti skid stuff like you might use to keep something from slipping around on something that is moving. I put it between the tank and base board making sure it was snug and wouldn't contact with the springs. Then I wrapped it around the tank, put it all back in the vinyl covering, sealed the end of the vinyl completely and fastened it down to the quietest place on the bottom of the cabinet. It is now quiet and doesn't feedback.
You might try it, or swing over to Polk City and I'll help you with it. Jerry Knapper
View user's profile Send private message Send e-mail

All times are GMT - 8 Hours
Jump to:  

Our Online Catalog
Strings, CDs, instruction,
steel guitars & accessories

www.SteelGuitarShopper.com

Steel Guitar Music
Instrumental steel guitar CDs for your permanent collection
www.SteelGuitarMusic.com

Please review our Forum Rules and Policies

The Steel Guitar Forum
148 South Cloverdale Blvd.
Cloverdale, CA 95425 USA

Support This Forum


BIAB Styles
Ray Price Shuffles for Band-in-a-Box
by Jim Baron
HTTP