INSTRUCTION STRINGS ACCESSORIES MUSIC LINKS
 Visit Our Catalog at SteelGuitarShopper.com for Steel Guitars, Strings, Instruction, Music and Accessories 
Forum Index
where steel players meet online
The Steel Guitar Forum

Post new topic weak reverb on Fender vibrolux reverb
Reply to topic
Author Topic:  weak reverb on Fender vibrolux reverb
Jerry Meek


From:
Colorado, USA
Post Posted 3 Sep 2017 7:24 pm     Reply with quote

I have a Vibrolux reverb has to be at 10 to be ok the rest of my fenders about 3 to 4. could the tube be weak or something harder to fix.
View user's profile Send private message Send e-mail
Rick Abbott


From:
Indiana, USA
Post Posted 4 Sep 2017 5:24 am     Reply with quote

I'd start by replacing the tubes on either side of the reverb transformer. 3rd and 4th tubes from the right.

12at7 reverb driver and 12ax7 (or 7025) reverb return/recovery tubes.
_________________
RICK ABBOTT
Sho~Bud D-10 Professional #7962
Gibson Console Grande, Lazy River Wiessenborn
Session 400, Bassman Amp W/Altec 418,
1953 Stromberg-Carlson AU-35
View user's profile Send private message Send e-mail
Jerry Meek


From:
Colorado, USA
Post Posted 4 Sep 2017 6:12 am     Vibrolux Reply with quote

Thanks I'll try that.
View user's profile Send private message Send e-mail
ajm


From:
Los Angeles
Post Posted 4 Sep 2017 7:20 am     Reply with quote

Let us know if it fixes it.
View user's profile Send private message
Michael Brebes


From:
Northridge CA
Post Posted 4 Sep 2017 8:39 am     Reply with quote

If you can jar the amp and hear the reverb springs bouncing around loudly on 10, then it is probably the driver tube. If you hear the springs weakly then it is probably the 12AX7 tube.
_________________
Michael Brebes
MSA D10 Classic/Rickenbacher B6/
Dickerson MOTS/Dobro D32 Hawaiian/
Goldtone Paul Beard Reso

Mesa Boogie Studio Pre/Hafler 3000
RP1/MPX100
View user's profile Send private message Send e-mail
Jerry Meek


From:
Colorado, USA
Post Posted 4 Sep 2017 11:31 am     Vibrolux Reply with quote

thanks that should make it easier to determine which tube I need of both
View user's profile Send private message Send e-mail
Ken Metcalf


From:
San Antonio Texas USA
Post Posted 4 Sep 2017 3:49 pm     Reply with quote

https://reverb.com/item/6195884-mooer-echoverb-digital-delay-reverb-pedal-4-wah-filter-effects-talk-effect-tap-new-model-2-modes
View user's profile Send private message Send e-mail
Godfrey Arthur


From:
Philippines
Post Posted 6 Sep 2017 3:18 pm     Reply with quote

While you're at it check to see if the tank connectors from the amp, RCA's I surmise, are clean and not corroded.



Check both male and female RCA connections on both ends of the cable amp/tank. Over time corrosion makes for intermittent connectivity which is a problem with RCA's especially if they are not well made.
_________________
From the Bronx via Manila
ShoBud The Pro 1
YES it's my REAL NAME!
View user's profile Send private message
Jerry Meek


From:
Colorado, USA
Post Posted 10 Sep 2017 11:26 am     vibrolux Reply with quote

After checking out with parts from my other fenders that worked fine it looks like it is the cables that is the problem got new cables on the way and then will know for sure. Over the years I've had very little amp problems and none serious. thanks for all the insightful infro.Jerry
View user's profile Send private message Send e-mail

All times are GMT - 8 Hours
Jump to:  

Our Online Catalog
Strings, CDs, instruction,
steel guitars & accessories

www.SteelGuitarShopper.com

Steel Guitar Music
Instrumental steel guitar CDs for your permanent collection
www.SteelGuitarMusic.com

Please review our Forum Rules and Policies

The Steel Guitar Forum
148 South Cloverdale Blvd.
Cloverdale, CA 95425 USA

Support This Forum


BIAB Styles
Ray Price Shuffles for Band-in-a-Box
by Jim Baron
HTTP